GBHackersMayura Kathir
AI Engine WordPress Plugin Exposes 100,000 WordPress Sites to Privilege Escalation Attacks
A critical vulnerability in the AI Engine WordPress plugin has left over 100,000 active installations worldwide exposed to privilege escalation. On 4 October 2025, security researchers identified a Sensitive Information Exposure flaw tracked as CVE-2025-11749, with a CVSS of 9.8 (Critical), affecting all versions up to and including 3.1.3; a patched version 3.1.4 was released on 19 October 2025.
The issue arises from improper REST API endpoint registration in the MCP component, which can reveal bearer tokens and allow unauthenticated attackers to escalate to administrator level. Administrators who enabled the No-Auth URL feature must rotate bearer tokens and update to 3.1.4 or later to restore security, as the token could already have been exposed.
Wordfence reported the vulnerability through its Bug Bounty Program on 4 October 2025, with a firewall rule deployed on 15 October 2025 and the patch issued on 19 October 2025; the researcher earned a $2,145 bounty. According to Wordfence, attackers can execute administrator-level commands, upload backdoors, or modify content once in control of a site.