CyberSIXT Search
Original
Image: GBHackers

GBHackersDivya

NVIDIA NeMo Flaw Enables Code Injection and Privilege Escalation Attacks

NVIDIA has issued security patches for two high-severity flaws in its NeMo Framework that could allow attackers to execute arbitrary code and escalate privileges on affected systems. The vulnerabilities affect all versions before 2.5.0, with CVEs CVE-2025-23361 and CVE-2025-33178 both scoring 7.8 on CVSS v3.1 and classified as High.

CVE-2025-23361 involves improper control of code generation in a script component, enabling complete code execution, privilege escalation, information disclosure and data tampering if exploited. CVE-2025-33178 affects the BERT services component and enables code injection via malicious data, leading to similar outcomes upon successful exploitation.

Both flaws require local access with low privileges and can be triggered by an authenticated attacker without user interaction, arising from improper input validation and code-generation controls (CWE-94). NVIDIA urges users to upgrade to version 2.5.0 or later, with the update available on its GitHub repository and PyPI. The flaws were reported by security researchers at TencentAISec and Guanheng Liu and Pinji Chen from the NISL lab at Tsinghua University.

Sources

On this device

Following

Intel

VendorsThreat actorsResearch reports

Settings

CyberSIXT summarises security news every 30 minutes.

↑↓ move↵ open⌘C copy CVE IDEsc close

Keyboard shortcuts

Everything works with a mouse or touch. Shortcuts are a faster path.

Search ⌘K
Search /
Next item J
Previous item K
Go to Today GT
Go to News GN
Go to CVEs GC
Go to Briefing GB
Reduce motion on this device