SecurityOnlineDdos
Cisco Warns of High-Severity Privilege Escalation Flaw (CVE-2025-20341) in Catalyst Center Virtual Appliance
Cisco warns of a high-severity privilege escalation flaw, CVE-2025-20341, in the Catalyst Center Virtual Appliance, according to Cisco. The advisory says the vulnerability could allow an authenticated, remote attacker to elevate privileges from the lowest Observer level to Administrator on an affected system, effectively giving full administrative control. It stems from insufficient validation of user-supplied input, with exploitation triggered by a specially crafted HTTP request.
A successful exploit could enable unauthorized modifications, including creating new user accounts or elevating the attacker’s own privileges. The flaw affects Catalyst Center Virtual Appliance versions earlier than 2.3.7.3-VA (vulnerable for 2.3.7.3-VA and later, fixed in 2.3.7.10-VA) and version 3.1 is not vulnerable; Cisco has released patched software and urges administrators to update immediately. As of the advisory date, there is no evidence of public exploitation. (Note: published 15 November 2025.)