Skip to content

Briefing · Monday 2 November 2026 · 07:00 UTC

BTCPay Server links hot-wallet thefts to older releases

By CyberSIXT Briefing · from 30 reports by 6 outlets · Editorial policy

BTCPay Server says attackers drained hot wallets on instances running version 2.4.1 or older, while it has no credible reports of drains on 2.4.7.cybersixt The project said traces indicate vulnerabilities fixed in 2.4.2 were used and attackers logged in as admin on affected servers, but it has not published its promised detailed account.cybersixt The update follows Sunday's warning to shut down older instances; Volexity's report that three Ivanti flaws were exploited adds detail to the access-chain story carried in the previous edition.cybersixtSANS ISC

BTCPay Server links hot-wallet thefts to older releases#

BTCPay Server said early on 2 November that attacks on Sunday night targeted instances running version 2.4.1 or older, released on July 23.cybersixt The project reported no credible hot-wallet drain reports for version 2.4.7, released on October 29, and said anyone running a version above 2.4.2 was not affected.cybersixt Lead developer Nicolas Dorier said traces showed attackers used vulnerabilities fixed in 2.4.2 and logged in as admin on affected servers.cybersixt Some hosting providers shut down older instances after the project's warning, while the project said it was investigating and promised a blog post with more detail.cybersixt

Rapid7 details exploitation of a BeyondTrust flaw#

Rapid7 published an analysis and Metasploit module for CVE-2026-102764, a BeyondTrust Remote Support flaw that lets unauthenticated attackers write files to an appliance and execute code as its operating-system user.SecurityOnline BeyondTrust confirmed two compromises on 29 August 2026, one on a hosted instance and one on a self-hosted appliance, before disclosing the flaw on 15 October.SecurityOnline Mandiant attributed the activity to ARMORY CASTLE, a suspected PRC-linked espionage actor previously tracked as UNC5221, and CISA added the vulnerability to its KEV catalogue on 16 October.SecurityOnline Self-hosted Remote Support versions 26.2.3 and earlier are affected unless patched; BeyondTrust said its SaaS service was patched on 9 October 2026.SecurityOnline Rapid7 tested version 24.1.2 but said it had not established the full affected range or fixed builds through testing, and BeyondTrust had not identified an exploit path in Privileged Remote Access.SecurityOnline

Ransomware hits unpatched Synology NAS devices#

SecurityOnline reported that a ransomware campaign encrypted storage volumes on Synology network-attached storage devices, primarily affecting internet-exposed appliances running outdated software.SecurityOnline The outlet attributed the attacks to known vulnerabilities rather than zero-days and cited Synology advisory SA-24:20 for CVE-2024-10441, a flaw in internal plugin services rated 9.8 on the CVSS scale.SecurityOnline The listed minimum fixed versions are DSM 7.4-90075, DSM 7.3.2-86009-4, DSM 7.2.2-72806-9 and DSM 7.2.1-69057.12.SecurityOnline SecurityOnline also cited Qihoo 360 analysts on exploitation of other flaws patched in September 2026, but did not identify those vulnerabilities or provide details about specific victims.SecurityOnline The outlet said DSM 6.x has reached end of life and will not receive security fixes.SecurityOnline

Also

  • Emergency apps. Ukraine's Air Alert app sent false warnings about radiation, chemical threats and street fighting on 1 November, while Russia's Emergency Situations Ministry said its app was hit by a cyberattack that sent fake information; neither government has disclosed how its app was compromised.cybersixtcybersixt
  • Canonical LXD. Canonical fixed CVE-2026-112816 in LXD and MicroCloud, a mutual-TLS flaw that could let an attacker impersonate a trusted client; the sources reported no exploitation.The Hacker NewsSecurityOnline
  • Dell PowerStore. Dell released PowerStoreT OS 5.1.0[.]0-2798105 for 44 vulnerabilities affecting 13 PowerStore models and said it had not reported exploitation.SecurityOnline
  • pgAdmin 4. The pgAdmin development team released version 9.19 on 29 October, fixing 15 vulnerabilities, including CVE-2026-116241, which can allow command execution through the Import and Export Data tool.SecurityOnline
  • Brotli. SecurityOnline said fixes for CVE-2026-111497, an out-of-bounds write affecting Brotli 1.0.3 through 1.2.0, are available in Google Brotli versions 1.0.10, 1.1.1 and 1.2.1, with updates also listed for several runtimes and software products.SecurityOnline
  • Apache Wicket. SecurityOnline reported that Apache Wicket disclosed 19 flaws across its 8.20.0, 9.25.0 and 10.12.0 branches, with no confirmed exploitation in the wild at the time of reporting.SecurityOnline

Watching

BTCPay Server has promised a blog post with more detail on the hot-wallet attacks; the method used to compromise Ukraine's and Russia's emergency apps remains undisclosed.cybersixtcybersixtcybersixt

Updated AboutDevelopersSign in