Skip to content
Sign in
CVE-2024-583519.8Critical

CVE-2024-58351: Flowise - Remote Code Execution via overrideConfig Parameter

Flowise

Fixed in 2.1.4 · Affected: Flowise before 2.1.4 · Exploitation: not established

ExploitationNot established

Not in CISA KEV as of catalogue 2026.11.06 (6 Nov)

  1. In CISA KEV: not seen
  2. Exploited (reported): not seen
  3. Scanning observed: not seen
  4. Proof of concept public: not seen
  5. Not establishedNothing in the sources we check
0.7%probability of exploitation in the next 30 days
51st percentile
050100

Higher than 51% of scored CVEs

9.8CriticalCVSS
LowCrit.

DescriptionNVD

Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.

Coverage1 article · 1 outlet

First in our coverage: SecurityWeek, 6 Nov.

  1. Attackers weaponise SAP flaws within days as AI bills soar
    SecurityWeek · first in our coverage · mentions it in passing

New articles also arrive in the RSS feed.

References

Updated AboutDevelopersSign in