Skip to content
Sign in
CVE-2026-1003008.7High

CVE-2026-100300: Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply thread

Apache Software Foundation · Apache ZooKeeper

Vendor fix available · Affected: Apache Software Foundation Apache ZooKeeper · Exploitation: not established

ExploitationNot established

Not in CISA KEV as of catalogue 2026.11.04 (4 Nov)

  1. In CISA KEV: not seen
  2. Exploited (reported): not seen
  3. Scanning observed: not seen
  4. Proof of concept public: not seen
  5. Not establishedNothing in the sources we check

No EPSS score yet. The score appears once FIRST publishes it.

8.7HighCVSS
LowHigh

DescriptionNVD

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Coverage1 article · 1 outlet

First in our coverage: SecurityOnline, 5 Nov.

  1. Apache fixes flaws across ZooKeeper, OpenOffice and ActiveMQ
    SecurityOnline · first in our coverage · mentions it in passing

New articles also arrive in the RSS feed.

References

Updated AboutDevelopersSign in