Apache Software Foundation Apache ActiveMQ vulnerability
Apache Software FoundationApache ActiveMQ
- Not in CISA KEV
- Vendor fix available
Higher than 65% of scored CVEs
Description NVD
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. The MessageServlet in the ActiveMQ web console API copies every JMS message property into an HTTP response header without any validation. This can allow overwriting and injecting security headers by setting them on JMS messages that are returned by the servlet. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ Web: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue. The MessageServlet has now been deprecated and disabled by default.
Coverage No articles yet
No CyberSIXT article names CVE-2026-42253 yet. New articles appear here and in the RSS feed.